Increased Latency on Lead Submission

Incident Report for Engine.tech

Resolved

Response times have returned to normal
Posted Jul 01, 2025 - 23:44 EDT

Update

We are continuing to investigate this issue.
Posted Jul 01, 2025 - 21:48 EDT

Update

The issue is limited to the /blocking/leads/rateTables endpoint.
Still working to identify the problem
Posted Jul 01, 2025 - 21:47 EDT

Investigating

We are currently investigating this issue.
Posted Jul 01, 2025 - 20:08 EDT
This incident affected: RateTable Creation and Lead Submission.