Submit Leads High Error Rate

Incident Report for Engine.tech

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 12:12 EST

Monitoring

We've applied patches and see error rates returning to normal.
Posted Mar 03, 2026 - 12:10 EST

Investigating

We've identified high error rates on our Leads submission endpoints
Posted Mar 03, 2026 - 12:02 EST
This incident affected: RateTable Creation, Lead Submission, and Lead Retrieval.