Increased Latency on some Rate Tables

Incident Report for Engine.tech

Resolved

The issue is now resolved
Posted May 15, 2026 - 15:27 EDT

Monitoring

We've implemented mitigations and identified the issue. Continuing to monitor as a more permanent measure is in place
Posted May 15, 2026 - 13:15 EDT

Identified

We've disabled Spark Filtering as a mitigation.
Latency should be returning to closer to baseline
Posted May 15, 2026 - 10:44 EDT

Investigating

Some rate tables are encountering increased latency on creation
Posted May 15, 2026 - 10:19 EDT
This incident affected: RateTable Creation.