Increased Error Rate on /leads Endpoints

Incident Report for Engine.tech

Resolved

The issue has been resolved
Posted Jul 31, 2025 - 13:53 EDT

Monitoring

An attempted resolution has been put in place.
We are monitoring the situation
Posted Jul 31, 2025 - 12:51 EDT

Identified

We've identified the problem. Currently working on a resolution
Posted Jul 31, 2025 - 12:29 EDT

Investigating

We are currently investigating increased error rates on the /leads endpoints
Posted Jul 31, 2025 - 12:18 EDT
This incident affected: RateTable Creation, RateTable Delivery, Lead Submission, and Lead Retrieval.