Ratetables / Leads API not working as expected

Incident Report for Engine.tech

Resolved

The scheduled database maintenance impacting the Ratetables / Leads API has been successfully completed. All services are now operating normally.
Posted Apr 08, 2025 - 03:06 EDT

Update

Update: Ratetables / Leads API – Temporary Disruptions Due to Scheduled Maintenance between 2 am and 5 am EST. There may be some disruptions during this time
Posted Apr 08, 2025 - 02:28 EDT

Investigating

The Ratetables API is currently experiencing unexpected behavior. Some endpoints may be returning incorrect data or failing to respond. Our team is actively investigating the issue to determine the root cause and implement a resolution. Updates will be provided as more information becomes available.
Posted Apr 08, 2025 - 02:14 EDT
This incident affected: RateTable Creation, RateTable Delivery, Lead Submission, and Lead Retrieval.