Increased Latency in Rate Table Creation

Incident Report for Engine.tech

Resolved

This incident has been resolved.
Posted May 19, 2026 - 10:25 EDT

Identified

We've identified an issue that results in increased latency on some Rate Table calls. We're actively working to resolve it
Posted May 19, 2026 - 07:59 EDT
This incident affected: RateTable Creation.