High Latency on Endpoints

Incident Report for Engine.tech

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 16:34 EDT

Monitoring

The fixes have been deployed. Continuing to monitor the latency
Posted Aug 20, 2025 - 16:24 EDT

Identified

We've noticed high latency on our endpoints.
The issue has been identified and we are working on the resolution
Posted Aug 20, 2025 - 16:21 EDT
This incident affected: RateTable Creation, RateTable Delivery, Lead Submission, and Lead Retrieval.